summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-06-08 18:18:46 (GMT)
committerGitHub <noreply@github.com>2022-06-08 18:18:46 (GMT)
commit22df2e0322300d25c1255ceb73cacc0ebd96b20e (patch)
tree362151533ff8f404498b12901a3aa35d4e8d58b0 /configure.ac
parent5442561c1a094b68900198bade616da9ed509ac8 (diff)
downloadcpython-22df2e0322300d25c1255ceb73cacc0ebd96b20e.zip
cpython-22df2e0322300d25c1255ceb73cacc0ebd96b20e.tar.gz
cpython-22df2e0322300d25c1255ceb73cacc0ebd96b20e.tar.bz2
gh-90473: Define HOSTRUNNER for WASI (GH-93606)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 07a178a..4c540ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1424,6 +1424,10 @@ then
HOSTRUNNER='node'
])
],
+ dnl TODO: support other WASI runtimes
+ dnl wasmtime starts the proces with "/" as CWD. For OOT builds add the
+ dnl directory containing _sysconfigdata to PYTHONPATH.
+ [WASI/*], [HOSTRUNNER='wasmtime run --env PYTHONPATH=$$(realpath --relative-to $(abs_srcdir) $(abs_builddir))/$$(cat pybuilddir.txt) --mapdir /::$(srcdir) --'],
[HOSTRUNNER='']
)
fi