summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2015-02-11 18:39:16 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2015-02-11 18:39:16 (GMT)
commit3d6c784371bccc2407048652bce50c5bccf9b1af (patch)
treef381d180c27968bf1ced9d7a395033bc64b126e8 /configure.ac
parent22fabe218d3d6d0198075bcd8d1e1ddf821102c1 (diff)
downloadcpython-3d6c784371bccc2407048652bce50c5bccf9b1af.zip
cpython-3d6c784371bccc2407048652bce50c5bccf9b1af.tar.gz
cpython-3d6c784371bccc2407048652bce50c5bccf9b1af.tar.bz2
Issue #23445: pydebug builds now use "gcc -Og" where possible, to make the resulting executable faster.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a0d0afa..8969279 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1119,7 +1119,11 @@ then
if test "$Py_DEBUG" = 'true' ; then
# Optimization messes up debuggers, so turn it off for
# debug builds.
- OPT="-g -O0 -Wall $STRICT_PROTO"
+ if "$CC" -v --help 2>/dev/null |grep -- -Og > /dev/null; then
+ OPT="-g -Og -Wall $STRICT_PROTO"
+ else
+ OPT="-g -O0 -Wall $STRICT_PROTO"
+ fi
else
OPT="-g $WRAP -O3 -Wall $STRICT_PROTO"
fi