summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-11-14 09:02:24 (GMT)
committerGitHub <noreply@github.com>2021-11-14 09:02:24 (GMT)
commit464e6616be86129e33af6d9e43540c260d6804d5 (patch)
treec3f516c93bf2e0bc58ee6b3868e5a8a6aab12977 /configure.ac
parent25835c518aa7446f3680b62c1fb43827e0f190d9 (diff)
downloadcpython-464e6616be86129e33af6d9e43540c260d6804d5.zip
cpython-464e6616be86129e33af6d9e43540c260d6804d5.tar.gz
cpython-464e6616be86129e33af6d9e43540c260d6804d5.tar.bz2
bpo-45800: Move pyexpat build setup into configure (GH-29547)
Settings for :mod:`pyexpat` C extension are now detected by ``configure``. The bundled ``expat`` library is built in ``Makefile``. Signed-off-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c3b52e3..f43030e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3017,6 +3017,20 @@ AC_ARG_WITH(system_expat,
AC_MSG_RESULT($with_system_expat)
+AS_VAR_IF([with_system_expat], [yes], [
+ LIBEXPAT_CFLAGS=""
+ LIBEXPAT_LDFLAGS="-lexpat"
+ LIBEXPAT_INTERNAL=
+], [
+ LIBEXPAT_CFLAGS="-I\$(srcdir)/Modules/expat"
+ LIBEXPAT_LDFLAGS="-lm \$(LIBEXPAT_A)"
+ LIBEXPAT_INTERNAL="\$(LIBEXPAT_A)"
+])
+
+AC_SUBST([LIBEXPAT_CFLAGS])
+AC_SUBST([LIBEXPAT_LDFLAGS])
+AC_SUBST([LIBEXPAT_INTERNAL])
+
# Check for use of the system libffi library
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,