summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2017-05-02 19:42:48 (GMT)
committerGitHub <noreply@github.com>2017-05-02 19:42:48 (GMT)
commit5facdbb29169c2799c42f887cef4cd9d087b0167 (patch)
tree3882246ae3de8854480446d49fa2745dc4aa228a /configure.ac
parent094909ad69a6654ac43c69ebdced060fbbbbede8 (diff)
downloadcpython-5facdbb29169c2799c42f887cef4cd9d087b0167.zip
cpython-5facdbb29169c2799c42f887cef4cd9d087b0167.tar.gz
cpython-5facdbb29169c2799c42f887cef4cd9d087b0167.tar.bz2
bpo-30232: Support Git worktree in configure.ac (#1391)
Don't test if .git/HEAD file exists, but only if the .git file (or directory) exists.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c58322d..69d2c13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,7 +29,7 @@ AC_SUBST(GITVERSION)
AC_SUBST(GITTAG)
AC_SUBST(GITBRANCH)
-if test -e $srcdir/.git/HEAD
+if test -e $srcdir/.git
then
AC_CHECK_PROG(HAS_GIT, git, found, not-found)
else