summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorINADA Naoki <methane@users.noreply.github.com>2017-06-29 06:31:38 (GMT)
committerGitHub <noreply@github.com>2017-06-29 06:31:38 (GMT)
commit6b42eb17649bed9615b6e6cecaefdb2f46990b2c (patch)
treeda7ca04b814551d5834b84281020d8fd49015035 /configure.ac
parent7526cadd64566725ffc56071a7208828a46ddbd8 (diff)
downloadcpython-6b42eb17649bed9615b6e6cecaefdb2f46990b2c.zip
cpython-6b42eb17649bed9615b6e6cecaefdb2f46990b2c.tar.gz
cpython-6b42eb17649bed9615b6e6cecaefdb2f46990b2c.tar.bz2
bpo-29585: Fix sysconfig.get_config_var("PYTHONFRAMEWORK") (GH-2483)
`PYTHONFRAMEWORK` is defined in `Makefile` and it shoulnd't be used in `pyconfig.h`. `sysconfig.py --generate-posix-vars` reads config vars from Makefile and `pyconfig.h`. Conflicting variables should be avoided. Especially, string config variables in Makefile are unquoted, but in `pyconfig.h` are keep quoted. So it should be private (starts with underscore).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 815769f..8253102 100644
--- a/configure.ac
+++ b/configure.ac
@@ -355,7 +355,7 @@ AC_SUBST(FRAMEWORKPYTHONW)
AC_SUBST(FRAMEWORKUNIXTOOLSPREFIX)
AC_SUBST(FRAMEWORKINSTALLAPPSPREFIX)
-AC_DEFINE_UNQUOTED(PYTHONFRAMEWORK, "${PYTHONFRAMEWORK}", [framework name])
+AC_DEFINE_UNQUOTED(_PYTHONFRAMEWORK, "${PYTHONFRAMEWORK}", [framework name])
##AC_ARG_WITH(dyld,
## AS_HELP_STRING([--with-dyld],