summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorƁukasz Langa <lukasz@langa.pl>2022-05-03 16:27:38 (GMT)
committerGitHub <noreply@github.com>2022-05-03 16:27:38 (GMT)
commit6c25bf07e86b6d8d5e50488835f70539f382d7e0 (patch)
tree1ba0b23ccfc45a397eb510de520995d080fbef1e /configure.ac
parentfeca9bbd1f6489f2b6d2783bfc22fdb96e45b69f (diff)
downloadcpython-6c25bf07e86b6d8d5e50488835f70539f382d7e0.zip
cpython-6c25bf07e86b6d8d5e50488835f70539f382d7e0.tar.gz
cpython-6c25bf07e86b6d8d5e50488835f70539f382d7e0.tar.bz2
gh-89452: Prefer gdbm-compat over ndbm (#92208)
This makes macOS gdbm provided by Homebrew not segfault through correct selection of the linked library (-lgdbm_compat) *AND* the correct ndbm-style header (gdbm-ndbm.h instead of the invalid ndbm.h).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 62da321..8c0711d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3850,7 +3850,7 @@ AC_CHECK_HEADERS([db.h], [
AC_MSG_CHECKING(for --with-dbmliborder)
AC_ARG_WITH(dbmliborder,
AS_HELP_STRING([--with-dbmliborder=db1:db2:...], [override order to check db backends for dbm; a valid value is a colon separated string with the backend names `ndbm', `gdbm' and `bdb'.]),
-[], [with_dbmliborder=ndbm:gdbm:bdb])
+[], [with_dbmliborder=gdbm:ndbm:bdb])
have_gdbm_dbmliborder=no
as_save_IFS=$IFS
@@ -3865,7 +3865,7 @@ for db in $with_dbmliborder; do
done
IFS=$as_save_IFS
AS_VAR_IF([with_dbmliborder], [error], [
- AC_MSG_ERROR([proper usage is --with-dbmliborder=db1:db2:... (ndbm:gdbm:bdb)])
+ AC_MSG_ERROR([proper usage is --with-dbmliborder=db1:db2:... (gdbm:ndbm:bdb)])
])
AC_MSG_RESULT($with_dbmliborder)