summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2021-09-25 12:36:26 (GMT)
committerGitHub <noreply@github.com>2021-09-25 12:36:26 (GMT)
commit7834ff26cbcd4d8394d64d80d9f51a364d38b1c6 (patch)
treee7c785c78db85d08be01a0f081589ea6d1a48614 /configure.ac
parent71f8ff45c62bd6b792919ac7c3804a8628ae12cb (diff)
downloadcpython-7834ff26cbcd4d8394d64d80d9f51a364d38b1c6.zip
cpython-7834ff26cbcd4d8394d64d80d9f51a364d38b1c6.tar.gz
cpython-7834ff26cbcd4d8394d64d80d9f51a364d38b1c6.tar.bz2
bpo-21302: Add nanosleep() implementation for time.sleep() in Unix (GH-28545)
Co-authored-by: Livius <egyszeregy@freemail.hu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a0694c..48d86ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4121,6 +4121,12 @@ AC_CHECK_FUNCS(clock_nanosleep, [], [
])
])
+AC_CHECK_FUNCS(nanosleep, [], [
+ AC_CHECK_LIB(rt, nanosleep, [
+ AC_DEFINE(HAVE_NANOSLEEP, 1)
+ ])
+])
+
AC_MSG_CHECKING(for major, minor, and makedev)
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
#if defined(MAJOR_IN_MKDEV)