summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordoko@ubuntu.com <doko@ubuntu.com>2012-06-30 15:05:13 (GMT)
committerdoko@ubuntu.com <doko@ubuntu.com>2012-06-30 15:05:13 (GMT)
commit9c7817e9ee0c6d8909a168ba9e12e87d9e7d6caf (patch)
tree683009e811dc87cbe8c319ce65d6c2379bbb323c /configure.ac
parentba01583eef8741deb837191aa2e58d860e756f41 (diff)
downloadcpython-9c7817e9ee0c6d8909a168ba9e12e87d9e7d6caf.zip
cpython-9c7817e9ee0c6d8909a168ba9e12e87d9e7d6caf.tar.gz
cpython-9c7817e9ee0c6d8909a168ba9e12e87d9e7d6caf.tar.bz2
- Issue #3754: Some unrelated configure.ac cleanups.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 60f8541..3ad7f49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2594,12 +2594,12 @@ AC_ARG_WITH(pymalloc,
if test -z "$with_pymalloc"
then
with_pymalloc="yes"
- ABIFLAGS="${ABIFLAGS}m"
fi
if test "$with_pymalloc" != "no"
then
AC_DEFINE(WITH_PYMALLOC, 1,
[Define if you want to compile in Python-specific mallocs])
+ ABIFLAGS="${ABIFLAGS}m"
fi
AC_MSG_RESULT($with_pymalloc)
@@ -2668,7 +2668,11 @@ then
else
MACHDEP_OBJS="$MACHDEP_OBJS $extra_machdep_objs"
fi
-AC_MSG_RESULT(MACHDEP_OBJS)
+if test -z "$MACHDEP_OBJS"; then
+ AC_MSG_RESULT([none])
+else
+ AC_MSG_RESULT([$MACHDEP_OBJS])
+fi
# checks for library functions
AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
@@ -3128,7 +3132,7 @@ fi
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
-if test $have_getaddrinfo = no -o "$ac_cv_buggy_getaddrinfo" = yes
+if test $have_getaddrinfo = no || test "$ac_cv_buggy_getaddrinfo" = yes
then
if test $ipv6 = yes
then