summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2013-12-08 14:21:08 (GMT)
committerChristian Heimes <christian@cheimes.de>2013-12-08 14:21:08 (GMT)
commitb02bcae56632d2744ec24db2a1fd3a35ab363fba (patch)
treeeced4a6b26e0d19d677c6c51fc9e8d166e23ea4f /configure.ac
parent5bb414d176b5c99d9f2500738fe77c47ea938763 (diff)
downloadcpython-b02bcae56632d2744ec24db2a1fd3a35ab363fba.zip
cpython-b02bcae56632d2744ec24db2a1fd3a35ab363fba.tar.gz
cpython-b02bcae56632d2744ec24db2a1fd3a35ab363fba.tar.bz2
Attempt to fix OpenIndiana build issue introduced by #19922
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2d701b1..25e1dc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -524,11 +524,17 @@ fi
# On HP-UX mbstate_t requires _INCLUDE__STDC_A1_SOURCE
case $ac_sys_system in
-hp*|HP*)
- AC_DEFINE(_INCLUDE__STDC_A1_SOURCE, 1, Define to include mbstate_t for mbrtowc)
- ;;
+ hp*|HP*)
+ define_stdc_a1=yes;;
+ *)
+ define_stdc_a1=no;;
esac
+if test $define_stdc_a1 = yes
+then
+ AC_DEFINE(_INCLUDE__STDC_A1_SOURCE, 1, Define to include mbstate_t for mbrtowc)
+fi
+
#
# SGI compilers allow the specification of the both the ABI and the
# ISA on the command line. Depending on the values of these switches,