summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gilbert <floppymaster@gmail.com>2021-10-11 23:24:03 (GMT)
committerGitHub <noreply@github.com>2021-10-11 23:24:03 (GMT)
commitbe21706f3760bec8bd11f85ce02ed6792b07f51f (patch)
tree37b0680391875eb8aaf608eac84f714c603560c5 /configure.ac
parentce3489cfdb9f0e050bdc45ce5d3902c2577ea683 (diff)
downloadcpython-be21706f3760bec8bd11f85ce02ed6792b07f51f.zip
cpython-be21706f3760bec8bd11f85ce02ed6792b07f51f.tar.gz
cpython-be21706f3760bec8bd11f85ce02ed6792b07f51f.tar.bz2
bpo-45433: Do not link libpython against libcrypt (GH-28881)
Save/restore LIBS when calling AC_SEARCH_LIBS(..., crypt). This avoid linking libpython with libcrypt.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c65b29..afdc683 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4085,6 +4085,8 @@ AC_CHECK_FUNCS(setpgrp,
# We search for both crypt and crypt_r as one or the other may be defined
# This gets us our -lcrypt in LIBS when required on the target platform.
+# Save/restore LIBS to avoid linking libpython with libcrypt.
+LIBS_SAVE=$LIBS
AC_SEARCH_LIBS(crypt, crypt)
AC_SEARCH_LIBS(crypt_r, crypt)
@@ -4099,6 +4101,7 @@ char *r = crypt_r("", "", &d);
[AC_DEFINE(HAVE_CRYPT_R, 1, [Define if you have the crypt_r() function.])],
[])
)
+LIBS=$LIBS_SAVE
AC_CHECK_FUNCS(clock_gettime, [], [
AC_CHECK_LIB(rt, clock_gettime, [