summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Panter <vadmium+py@gmail.com>2016-09-12 01:32:03 (GMT)
committerMartin Panter <vadmium+py@gmail.com>2016-09-12 01:32:03 (GMT)
commitc5ee3caa807abeb14b586117ce36bc1c2a762390 (patch)
treed79da77b1a09d8dbeb0f2c9db0326e5ebfc4b096 /configure.ac
parent44c19eccf9fd8258f8d939fe30b79b644b2c235a (diff)
downloadcpython-c5ee3caa807abeb14b586117ce36bc1c2a762390.zip
cpython-c5ee3caa807abeb14b586117ce36bc1c2a762390.tar.gz
cpython-c5ee3caa807abeb14b586117ce36bc1c2a762390.tar.bz2
Issue #28066: Fix include search directory logic for out-of-tree builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 36758d4..381bab0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,7 @@ AC_PREREQ(2.65)
AC_INIT(python, PYTHON_VERSION, https://bugs.python.org/)
AC_SUBST(BASECPPFLAGS)
-if test "$abs_srcdir" != "$abs_builddir"; then
+if test "$srcdir" != . -a "$srcdir" != "$(pwd)"; then
# If we're building out-of-tree, we need to make sure the following
# resources get picked up before their $srcdir counterparts.
# Objects/ -> typeslots.inc