summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2015-01-06 12:54:58 (GMT)
committerVictor Stinner <victor.stinner@gmail.com>2015-01-06 12:54:58 (GMT)
commitfcfed1991382f9697df574fae4115a9f815adca0 (patch)
tree5f9519dcdc56aab61eea2e7d6ef280f1f70e47f5 /configure.ac
parent9d01717f373d0180e2804c827efbc40d8cf72063 (diff)
downloadcpython-fcfed1991382f9697df574fae4115a9f815adca0.zip
cpython-fcfed1991382f9697df574fae4115a9f815adca0.tar.gz
cpython-fcfed1991382f9697df574fae4115a9f815adca0.tar.bz2
Issue #21356: Make ssl.RAND_egd() optional to support LibreSSL. The
availability of the function is checked during the compilation. Patch written by Bernard Spil.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 21f4152..a0d0afa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2238,6 +2238,9 @@ AC_MSG_RESULT($SHLIBS)
AC_CHECK_LIB(sendfile, sendfile)
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+AC_CHECK_LIB(crypto, RAND_egd,
+ AC_DEFINE(HAVE_RAND_EGD, 1,
+ [Define if the libcrypto has RAND_egd]))
# only check for sem_init if thread support is requested
if test "$with_threads" = "yes" -o -z "$with_threads"; then