summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2021-10-15 17:45:34 (GMT)
committerGitHub <noreply@github.com>2021-10-15 17:45:34 (GMT)
commit00ffc4513df7b89a168e88da4d1e3ac367f7682f (patch)
treee3b57e2fe5eab5bf559fe850a3a8ed070da2d3c0 /configure.ac
parent51f8196d05f0e271358eee0f90fe044b20449fb5 (diff)
downloadcpython-00ffc4513df7b89a168e88da4d1e3ac367f7682f.zip
cpython-00ffc4513df7b89a168e88da4d1e3ac367f7682f.tar.gz
cpython-00ffc4513df7b89a168e88da4d1e3ac367f7682f.tar.bz2
bpo-45440: Remove pymath.c fallbacks (GH-28977)
Remove fallbacks for missing round(), copysign() and hypot() in Python/pymath.c. Python now requires these functions to build. These fallbacks were needed on Visual Studio 2012 and older. They are no longer needed since Visual Stuido 2013. Python is now built with Visual Studio 2017 or newer since Python 3.6.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1d0c753..ab3fc28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4675,8 +4675,8 @@ fi
LIBS_SAVE=$LIBS
LIBS="$LIBS $LIBM"
-AC_CHECK_FUNCS([acosh asinh atanh copysign erf erfc expm1 finite gamma])
-AC_CHECK_FUNCS([hypot lgamma log1p log2 round tgamma])
+AC_CHECK_FUNCS([acosh asinh atanh erf erfc expm1 finite gamma])
+AC_CHECK_FUNCS([lgamma log1p log2 tgamma])
# For multiprocessing module, check that sem_open
# actually works. For FreeBSD versions <= 7.2,