summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-11-22 11:09:14 (GMT)
committerGitHub <noreply@github.com>2021-11-22 11:09:14 (GMT)
commit29699a2a2aa2f0d6e790beeae55967fc2f35fe50 (patch)
tree48030cd4d4e747d2bc0c74d4090f18fa30697adb /configure.ac
parent39f7d2ff01eb03f1dd87a019472a32cde6250e84 (diff)
downloadcpython-29699a2a2aa2f0d6e790beeae55967fc2f35fe50.zip
cpython-29699a2a2aa2f0d6e790beeae55967fc2f35fe50.tar.gz
cpython-29699a2a2aa2f0d6e790beeae55967fc2f35fe50.tar.bz2
bpo-45847: Various PY_STDLIB_MOD cleanups (GH-29697)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ee379b7..3b00735 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6037,12 +6037,9 @@ AC_DEFUN([PY_STDLIB_MOD], [
m4_pushdef([modstate], [py_cv_module_$1])dnl
AS_CASE([$py_stdlib_not_available],
[*$1*], [modstate=n/a],
- [
- AS_IF(m4_ifblank([$2], [true], [$2]),
+ [AS_IF(m4_ifblank([$2], [true], [$2]),
[AS_IF([m4_ifblank([$3], [true], [$3])], [modstate=yes], [modstate=missing])],
- [modstate=disabled]
- )
- ]
+ [modstate=disabled])]
)
_MODULE_BLOCK_ADD(modcond, [$modstate])
AS_VAR_IF([modstate], [yes], [
@@ -6060,13 +6057,14 @@ dnl PY_STDLIB_MOD_SIMPLE([NAME], [CFLAGS], [LDFLAGS])
dnl cflags and ldflags are optional
AC_DEFUN([PY_STDLIB_MOD_SIMPLE], [
m4_pushdef([modcond], [MODULE_]m4_toupper([$1]))dnl
- AM_CONDITIONAL(modcond, [true])
+ AM_CONDITIONAL(modcond, [true])dnl
+ _MODULE_BLOCK_ADD(modcond, [yes])dnl
m4_ifval([$2], [
_MODULE_BLOCK_ADD([MODULE_]m4_toupper([$1])[_CFLAGS], [$2])
- ])
+ ])dnl
m4_ifval([$3], [
_MODULE_BLOCK_ADD([MODULE_]m4_toupper([$1])[_LDFLAGS], [$3])
- ])
+ ])dnl
m4_popdef([modcond])dnl
])