summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDong-hee Na <donghee.na@python.org>2023-04-17 14:14:18 (GMT)
committerGitHub <noreply@github.com>2023-04-17 14:14:18 (GMT)
commit5d9762e7cf90444b03b43262be8001ff83401aac (patch)
treefcff33139fa6c70542a7e75089f1e981ddfde336 /configure.ac
parent76933df10afc958b2db2a6bcff7509285fbf5fcf (diff)
downloadcpython-5d9762e7cf90444b03b43262be8001ff83401aac.zip
cpython-5d9762e7cf90444b03b43262be8001ff83401aac.tar.gz
cpython-5d9762e7cf90444b03b43262be8001ff83401aac.tar.bz2
gh-101525: Fix make test if the --enable-bolt enabled (gh-103574)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d9eb46..3f20d89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1938,6 +1938,13 @@ if test "$Py_BOLT" = 'true' ; then
DEF_MAKE_ALL_RULE="bolt-opt"
DEF_MAKE_RULE="build_all"
+ AC_SUBST(READELF)
+ AC_CHECK_TOOLS(READELF, [readelf], "notfound")
+ if test "$READELF" == "notfound"
+ then
+ AC_MSG_ERROR([readelf is required for a --enable-bolt build but could not be found.])
+ fi
+
# -fno-reorder-blocks-and-partition is required for bolt to work.
# Possibly GCC only.
AX_CHECK_COMPILE_FLAG([-fno-reorder-blocks-and-partition],[