summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2017-04-21 06:52:19 (GMT)
committerGitHub <noreply@github.com>2017-04-21 06:52:19 (GMT)
commit791dc831198f3ecc1531f8e6f05debf4ce234d00 (patch)
treedebedec99881ffb16db1298e05360d398bb5378c /configure.ac
parentf60c9e54f501065f3be2a4cfb4c387dfa2f243a9 (diff)
downloadcpython-791dc831198f3ecc1531f8e6f05debf4ce234d00.zip
cpython-791dc831198f3ecc1531f8e6f05debf4ce234d00.tar.gz
cpython-791dc831198f3ecc1531f8e6f05debf4ce234d00.tar.bz2
remove configure test for inline keyword (#1231)
We require C99, so a configure test for this standard feature is not needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 73e64fd..d7316b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1078,13 +1078,6 @@ case `"$ac_prog" -V 2>&1 < /dev/null` in
esac
AC_MSG_RESULT($GNULD)
-AC_C_INLINE
-if test "$ac_cv_c_inline" != no ; then
- AC_DEFINE(USE_INLINE, 1, [Define to use the C99 inline keyword.])
- AC_SUBST(USE_INLINE)
-fi
-
-
AC_MSG_CHECKING(for --enable-shared)
AC_ARG_ENABLE(shared,
AS_HELP_STRING([--enable-shared], [disable/enable building shared python library]))