summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorErlend E. Aasland <erlend.aasland@protonmail.com>2023-06-01 21:44:25 (GMT)
committerGitHub <noreply@github.com>2023-06-01 21:44:25 (GMT)
commit8a8ebf2e3ddb880806237c7a5983f9744f7c215f (patch)
tree68f34fc411bc77c53897a352067a8bc886dcc48b /configure.ac
parent60f8117d0c685c2923b7cb17b725b67cd41e8410 (diff)
downloadcpython-8a8ebf2e3ddb880806237c7a5983f9744f7c215f.zip
cpython-8a8ebf2e3ddb880806237c7a5983f9744f7c215f.tar.gz
cpython-8a8ebf2e3ddb880806237c7a5983f9744f7c215f.tar.bz2
GH-89886: Bump to GNU Autoconf v2.71 (#104925)
Co-authored-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fd33ab2..f8f428a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,13 +2,20 @@ dnl ***************************************************
dnl * Please run autoreconf -if to test your changes! *
dnl ***************************************************
dnl
-dnl Python's configure.ac file requires autoconf 2.69 and autoconf-archive.
+dnl Python's configure script requires autoconf 2.71, autoconf-archive,
+dnl pkgconf's m4 macros.
+dnl
+dnl It is recommended to use a cpython_autoconf container to regenerate the
+dnl configure script:
+dnl
+dnl podman run --rm --pull=always -v $(pwd):/src:Z quay.io/tiran/cpython_autoconf:271
+dnl docker run --rm --pull=always -v $(pwd):/src quay.io/tiran/cpython_autoconf:271
dnl
# Set VERSION so we only need to edit in one place (i.e., here)
m4_define([PYTHON_VERSION], [3.13])
-AC_PREREQ([2.69])
+AC_PREREQ([2.71])
AC_INIT([python],[PYTHON_VERSION],[https://github.com/python/cpython/issues/])