summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDong-hee Na <donghee.na@python.org>2023-05-24 10:10:46 (GMT)
committerGitHub <noreply@github.com>2023-05-24 10:10:46 (GMT)
commitc43785192c97698a0217a680b30baae22106ed3e (patch)
treeb203802dc181a0776e033b94384a0251db93f433 /configure.ac
parentc8cf9b42eb2bfbd4c3e708ec28d32430248a1d7a (diff)
downloadcpython-c43785192c97698a0217a680b30baae22106ed3e.zip
cpython-c43785192c97698a0217a680b30baae22106ed3e.tar.gz
cpython-c43785192c97698a0217a680b30baae22106ed3e.tar.bz2
gh-101282: Enclose BOLT_APPLY_FLAGS value in double quotes (gh-104752)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 17 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index d5cb822..44b2ced 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2087,23 +2087,23 @@ if test -z "${BOLT_APPLY_FLAGS}"
then
AS_VAR_SET(
[BOLT_APPLY_FLAGS],
- [m4_join([ ],
- [-update-debug-sections],
- [-reorder-blocks=ext-tsp],
- [-reorder-functions=hfsort+],
- [-split-functions],
- [-icf=1],
- [-inline-all],
- [-split-eh],
- [-reorder-functions-use-hot-size],
- [-peepholes=none],
- [-jump-tables=aggressive],
- [-inline-ap],
- [-indirect-call-promotion=all],
- [-dyno-stats],
- [-use-gnu-stack],
- [-frame-opt=hot]
- )]
+ [m4_normalize("
+ -update-debug-sections
+ -reorder-blocks=ext-tsp
+ -reorder-functions=hfsort+
+ -split-functions
+ -icf=1
+ -inline-all
+ -split-eh
+ -reorder-functions-use-hot-size
+ -peepholes=none
+ -jump-tables=aggressive
+ -inline-ap
+ -indirect-call-promotion=all
+ -dyno-stats
+ -use-gnu-stack
+ -frame-opt=hot
+ ")]
)
fi
AC_MSG_RESULT([$BOLT_APPLY_FLAGS])