summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-06-24 15:03:42 (GMT)
committerGitHub <noreply@github.com>2022-06-24 15:03:42 (GMT)
commite69306f08b9be84ccdd0a1c6601ec229c4e5b377 (patch)
treeae26c9a084846fa80a90f95628cb6898d8c11dc1 /configure.ac
parent51fd4de101349bbea8afa4e212489f4b87e3a99b (diff)
downloadcpython-e69306f08b9be84ccdd0a1c6601ec229c4e5b377.zip
cpython-e69306f08b9be84ccdd0a1c6601ec229c4e5b377.tar.gz
cpython-e69306f08b9be84ccdd0a1c6601ec229c4e5b377.tar.bz2
gh-84461: Build Emscripten with WASM BigInt support (#94219)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b70532..f9abd85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2028,6 +2028,9 @@ AS_CASE([$ac_sys_system],
dnl Start with 20 MB and allow to grow
AS_VAR_APPEND([LDFLAGS_NODIST], [" -sALLOW_MEMORY_GROWTH -sTOTAL_MEMORY=20971520"])
+ dnl map int64_t and uint64_t to JS bigint
+ AS_VAR_APPEND([LDFLAGS_NODIST], [" -sWASM_BIGINT"])
+
dnl Include file system support
AS_VAR_APPEND([LDFLAGS_NODIST], [" -sFORCE_FILESYSTEM -lidbfs.js -lnodefs.js -lproxyfs.js -lworkerfs.js"])