summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMalcolm Smith <smith@chaquo.com>2024-04-30 14:00:31 (GMT)
committerGitHub <noreply@github.com>2024-04-30 14:00:31 (GMT)
commit3b268f4edc02b22257d745363b5cae199b6e5720 (patch)
tree6a485b90d723817ae9a16b4bad5995f77698a364 /configure.ac
parent11f8348d78c22f85694d7a424541b34d6054a8ee (diff)
downloadcpython-3b268f4edc02b22257d745363b5cae199b6e5720.zip
cpython-3b268f4edc02b22257d745363b5cae199b6e5720.tar.gz
cpython-3b268f4edc02b22257d745363b5cae199b6e5720.tar.bz2
gh-116622: Redirect stdout and stderr to system log when embedded in an Android app (#118063)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a2d6b13..7681ea3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1192,6 +1192,9 @@ if $CPP $CPPFLAGS conftest.c >conftest.out 2>/dev/null; then
AC_DEFINE_UNQUOTED([ANDROID_API_LEVEL], [$ANDROID_API_LEVEL],
[The Android API level.])
+ # For __android_log_write() in Python/pylifecycle.c.
+ LIBS="$LIBS -llog"
+
AC_MSG_CHECKING([for the Android arm ABI])
AC_MSG_RESULT([$_arm_arch])
if test "$_arm_arch" = 7; then