summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Bierma <zintensitydev@gmail.com>2024-09-16 20:03:16 (GMT)
committerGitHub <noreply@github.com>2024-09-16 20:03:16 (GMT)
commit3b45df03a4bd0e21edec43144b8d9bac689d23a0 (patch)
treee4a80ab3c8fccedacf0b77abd4fa0b424bb55410 /configure.ac
parent44052b5f18c5d605d33bf3207b5c918127cf0e82 (diff)
downloadcpython-3b45df03a4bd0e21edec43144b8d9bac689d23a0.zip
cpython-3b45df03a4bd0e21edec43144b8d9bac689d23a0.tar.gz
cpython-3b45df03a4bd0e21edec43144b8d9bac689d23a0.tar.bz2
gh-124043: Disallow mixing `--with-trace-refs` and `--disable-gil` (#124078)
Tracing references is not currently thread-safe in the free-threaded build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5fc7e08..ab6233a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1777,6 +1777,10 @@ then
[Define if you want to enable tracing references for debugging purpose])
fi
+if test "$disable_gil" = "yes" -a "$with_trace_refs" = "yes";
+then
+ AC_MSG_ERROR([--disable-gil cannot be used with --with-trace-refs])
+fi
# Check for --enable-pystats
AC_MSG_CHECKING([for --enable-pystats])