summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJesús Cea <jcea@jcea.es>2019-09-28 01:44:32 (GMT)
committerGitHub <noreply@github.com>2019-09-28 01:44:32 (GMT)
commit52d1b86bde2b772a76919c76991c326384954bf1 (patch)
treed50eee49a885b7b38e58b38ff3fd4cbf4db7a29d /configure.ac
parente8650a4f8c7fb76f570d4ca9c1fbe44e91c8dfaa (diff)
downloadcpython-52d1b86bde2b772a76919c76991c326384954bf1.zip
cpython-52d1b86bde2b772a76919c76991c326384954bf1.tar.gz
cpython-52d1b86bde2b772a76919c76991c326384954bf1.tar.bz2
bpo-38301: In Solaris family, we must be sure to use '-D_REENTRANT' (#16446)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69e2a5e..917a908 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3063,6 +3063,9 @@ then
# Defining _REENTRANT on system with POSIX threads should not hurt.
AC_DEFINE(_REENTRANT)
posix_threads=yes
+ if test "$ac_sys_system" = "SunOS"; then
+ CFLAGS="$CFLAGS -D_REENTRANT"
+ fi
elif test "$ac_cv_kpthread" = "yes"
then
CC="$CC -Kpthread"