summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Keith-Magee <russell@keith-magee.com>2024-07-16 04:23:35 (GMT)
committerGitHub <noreply@github.com>2024-07-16 04:23:35 (GMT)
commit7e91e0dcfe2faab1e1a4630e6f745aa30ca87b3d (patch)
tree648f93972c720cb1cc5918cea30414e6f5c48427 /configure.ac
parent2bac2b86b1486f15038fb246835e04bb1b213cd8 (diff)
downloadcpython-7e91e0dcfe2faab1e1a4630e6f745aa30ca87b3d.zip
cpython-7e91e0dcfe2faab1e1a4630e6f745aa30ca87b3d.tar.gz
cpython-7e91e0dcfe2faab1e1a4630e6f745aa30ca87b3d.tar.bz2
gh-120831: Increase the default minimum supported iOS version to 13.0 (#121250)
Increases the default minimum iOS version to 13.0. Co-authored-by: Erlend E. Aasland <erlend.aasland@protonmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index df146cc..190f1f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,7 +382,7 @@ AC_MSG_RESULT(["$MACHDEP"])
# On cross-compile builds, configure will look for a host-specific compiler by
# prepending the user-provided host triple to the required binary name.
#
-# On iOS, this results in binaries like "arm64-apple-ios12.0-simulator-gcc",
+# On iOS, this results in binaries like "arm64-apple-ios13.0-simulator-gcc",
# which isn't a binary that exists, and isn't very convenient, as it contains the
# iOS version. As the default cross-compiler name won't exist, configure falls
# back to gcc, which *definitely* won't work. We're providing wrapper scripts for
@@ -774,8 +774,10 @@ if test "$cross_compiling" = yes; then
_host_device=${_host_device:=os}
# IPHONEOS_DEPLOYMENT_TARGET is the minimum supported iOS version
+ AC_MSG_CHECKING([iOS deployment target])
IPHONEOS_DEPLOYMENT_TARGET=${_host_os:3}
- IPHONEOS_DEPLOYMENT_TARGET=${IPHONEOS_DEPLOYMENT_TARGET:=12.0}
+ IPHONEOS_DEPLOYMENT_TARGET=${IPHONEOS_DEPLOYMENT_TARGET:=13.0}
+ AC_MSG_RESULT([$IPHONEOS_DEPLOYMENT_TARGET])
case "$host_cpu" in
aarch64)