summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Nelson <trent@trent.me>2012-10-16 15:04:04 (GMT)
committerTrent Nelson <trent@trent.me>2012-10-16 15:04:04 (GMT)
commit6603118125164b927d79eab89263a07a12406481 (patch)
tree7859185ce2e0f04b90aefd0b52af5024503059d8 /configure.ac
parent9effe699b7858a4a654b34915bc0e2cbec0de1f3 (diff)
downloadcpython-6603118125164b927d79eab89263a07a12406481.zip
cpython-6603118125164b927d79eab89263a07a12406481.tar.gz
cpython-6603118125164b927d79eab89263a07a12406481.tar.bz2
Issue #15819: tweak logic in previous commit (617591e7d708).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9222c88..116e03e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -833,7 +833,7 @@ fi
BUILDDIR="`pwd`"
AC_SUBST(BUILDDIR)
AC_SUBST(BASECPPFLAGS)
-if test "$srcdir" != "$BUILDDIR"; then
+if test "$srcdir" != "." -a "$srcdir" != "$BUILDDIR"; then
# If we're building out-of-tree, we need to make sure the following
# resources get picked up before their $srcdir counterparts.
# Objects/ -> typeslots.inc