summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2013-01-17 19:41:56 (GMT)
committerStefan Krah <skrah@bytereef.org>2013-01-17 19:41:56 (GMT)
commit8c8adf6db7029d1350b8c2d4c9583ff995a9a97d (patch)
treec62fd36eff9930a8552e0204528639559ee07861 /configure.ac
parentebee49a48739fed72e9a4607a8fb975146a029d3 (diff)
downloadcpython-8c8adf6db7029d1350b8c2d4c9583ff995a9a97d.zip
cpython-8c8adf6db7029d1350b8c2d4c9583ff995a9a97d.tar.gz
cpython-8c8adf6db7029d1350b8c2d4c9583ff995a9a97d.tar.bz2
Issue #16987: Fix definition of SHLIB_EXT.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ec8f4ce..fe37419 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1898,7 +1898,6 @@ AC_SUBST(BLDSHARED)
AC_SUBST(CCSHARED)
AC_SUBST(LINKFORSHARED)
-AC_DEFINE_UNQUOTED(SHLIB_EXT, "$SO", [Define this to be extension of shared libraries (including the dot!).])
# LDSHARED is the ld *command* used to create shared library
# -- "cc -G" on SunOS 5.x, "ld -shared" on IRIX 5
# (Shared libraries in this instance are shared modules to be loaded into
@@ -3956,6 +3955,8 @@ else
fi
AC_MSG_RESULT($SO)
+AC_DEFINE_UNQUOTED(SHLIB_EXT, "$SO", [Define this to be extension of shared libraries (including the dot!).])
+
# Check whether right shifting a negative integer extends the sign bit
# or fills with zeros (like the Cray J90, according to Tim Peters).
AC_MSG_CHECKING(whether right shift extends the sign bit)