summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2013-08-21 11:26:34 (GMT)
committerChristian Heimes <christian@cheimes.de>2013-08-21 11:26:34 (GMT)
commit6acbe2aaa385ada342ac9421333fce083041f06f (patch)
treeb1de03775bdb9e03730fa8bb99d7b946986ce973 /configure.ac
parent5bb1b1dd6f94af0e8cb2d4a1686bc4882147ba66 (diff)
parentf77b4b20e931dd0247a176db856723fe1203d32e (diff)
downloadcpython-6acbe2aaa385ada342ac9421333fce083041f06f.zip
cpython-6acbe2aaa385ada342ac9421333fce083041f06f.tar.gz
cpython-6acbe2aaa385ada342ac9421333fce083041f06f.tar.bz2
Issue #18747: Re-seed OpenSSL's pseudo-random number generator after fork.
A pthread_atfork() child handler is used to seeded the PRNG with pid, time and some stack data.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 030b923..47f5c57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2512,6 +2512,7 @@ if test "$posix_threads" = "yes"; then
[Define if pthread_sigmask() does not work on your system.])
;;
esac])
+ AC_CHECK_FUNCS(pthread_atfork)
fi