summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2013-11-22 06:42:25 (GMT)
committerNed Deily <nad@acm.org>2013-11-22 06:42:25 (GMT)
commitb8f944f0b76ebfeecb181498868f10b273981668 (patch)
treea818ddc5a97ce0095936b9aebc1da0559f24afb5 /configure.ac
parentc06d6fdc37a70c28feaac60b06047b9f6357c05f (diff)
downloadcpython-b8f944f0b76ebfeecb181498868f10b273981668.zip
cpython-b8f944f0b76ebfeecb181498868f10b273981668.tar.gz
cpython-b8f944f0b76ebfeecb181498868f10b273981668.tar.bz2
Issue #19649: On OS X, the same set of file names are now installed
in bin directories for all configurations: non-framework vs framework, and single arch vs universal builds. pythonx.y-32 is now always installed for 64-bit/32-bit universal builds. The obsolete and undocumented pythonw* symlinks are no longer installed anywhere.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ba7d03..02f481e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -250,6 +250,7 @@ AC_ARG_ENABLE(framework,
FRAMEWORKINSTALLLAST=
FRAMEWORKALTINSTALLFIRST=
FRAMEWORKALTINSTALLLAST=
+ FRAMEWORKPYTHONW=
if test "x${prefix}" = "xNONE"; then
FRAMEWORKUNIXTOOLSPREFIX="${ac_default_prefix}"
else
@@ -264,6 +265,7 @@ AC_ARG_ENABLE(framework,
FRAMEWORKALTINSTALLFIRST="frameworkinstallstructure "
FRAMEWORKINSTALLLAST="frameworkinstallmaclib frameworkinstallapps frameworkinstallunixtools"
FRAMEWORKALTINSTALLLAST="frameworkinstallmaclib frameworkinstallapps frameworkaltinstallunixtools"
+ FRAMEWORKPYTHONW="frameworkpythonw"
FRAMEWORKINSTALLAPPSPREFIX="/Applications"
if test "x${prefix}" = "xNONE" ; then
@@ -325,6 +327,7 @@ AC_ARG_ENABLE(framework,
FRAMEWORKINSTALLLAST=
FRAMEWORKALTINSTALLFIRST=
FRAMEWORKALTINSTALLLAST=
+ FRAMEWORKPYTHONW=
if test "x${prefix}" = "xNONE" ; then
FRAMEWORKUNIXTOOLSPREFIX="${ac_default_prefix}"
else
@@ -342,6 +345,7 @@ AC_SUBST(FRAMEWORKINSTALLFIRST)
AC_SUBST(FRAMEWORKINSTALLLAST)
AC_SUBST(FRAMEWORKALTINSTALLFIRST)
AC_SUBST(FRAMEWORKALTINSTALLLAST)
+AC_SUBST(FRAMEWORKPYTHONW)
AC_SUBST(FRAMEWORKUNIXTOOLSPREFIX)
AC_SUBST(FRAMEWORKINSTALLAPPSPREFIX)