summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2013-05-11 18:00:05 (GMT)
committerBenjamin Peterson <benjamin@python.org>2013-05-11 18:00:05 (GMT)
commitfeb51492442881994f8d42dddfac2763794dbaec (patch)
treed9d569c5ee8688a3f960266c7a590105e4929f4e /configure.ac
parent8b0e98426dd0e1fde93715256413bc707759db6f (diff)
downloadcpython-feb51492442881994f8d42dddfac2763794dbaec.zip
cpython-feb51492442881994f8d42dddfac2763794dbaec.tar.gz
cpython-feb51492442881994f8d42dddfac2763794dbaec.tar.bz2
-Wformat is needed by gcc 4.8 (closes #17547)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6d54b16..9179fe6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1331,7 +1331,7 @@ if test "$GCC" = "yes"
then
AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
],[