summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2014-08-10 03:04:19 (GMT)
committerBenjamin Peterson <benjamin@python.org>2014-08-10 03:04:19 (GMT)
commitb30802b7a8a6e653e098cdb0108a729700e9eaaa (patch)
tree69149308a8227b2387c6e21c2e99cbfffe785fd9 /configure.ac
parenta61d058bf97291a51cc6481a3e76c2aa5500b37c (diff)
parentacb8c5234302f8057b331abaafb2cc8697daf58f (diff)
downloadcpython-b30802b7a8a6e653e098cdb0108a729700e9eaaa.zip
cpython-b30802b7a8a6e653e098cdb0108a729700e9eaaa.tar.gz
cpython-b30802b7a8a6e653e098cdb0108a729700e9eaaa.tar.bz2
merge 3.4 (#21121)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f396984..193c99c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1147,6 +1147,7 @@ then
fi
AC_SUBST(BASECFLAGS)
+AC_SUBST(CFLAGS_NODIST)
# The -arch flags for universal builds on OSX
UNIVERSAL_ARCH_FLAGS=
@@ -1231,7 +1232,7 @@ yes)
if test $ac_cv_declaration_after_statement_warning = yes
then
- BASECFLAGS="$BASECFLAGS -Werror=declaration-after-statement"
+ CFLAGS_NODIST="$CFLAGS_NODIST -Werror=declaration-after-statement"
fi
AC_MSG_CHECKING(if we can turn on $CC mixed sign comparison warning)