summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2014-08-22 20:32:49 (GMT)
committerNed Deily <nad@acm.org>2014-08-22 20:32:49 (GMT)
commitfcbc246e9f02cc780970defbcfa01767b7e3a3c6 (patch)
treeffd688ef004d7d04328ecbf1d7401df1effe22e7 /configure.ac
parent0242f79051cd43343bafa797c2bfa9512f7be6c2 (diff)
downloadcpython-fcbc246e9f02cc780970defbcfa01767b7e3a3c6.zip
cpython-fcbc246e9f02cc780970defbcfa01767b7e3a3c6.tar.gz
cpython-fcbc246e9f02cc780970defbcfa01767b7e3a3c6.tar.bz2
Issue #21166: Prevent possible segfaults and other random failures of
python --generate-posix-vars in pybuilddir.txt build target by ensuring that pybuilddir.txt is always regenerated when configure is run and that the newly built skeleton python does not inadvertently import modules from previously installed instances.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 418e16f..9698ea0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,9 @@ AC_CANONICAL_HOST
AC_SUBST(build)
AC_SUBST(host)
+# pybuilddir.txt will be created by --generate-posix-vars in the Makefile
+rm -f pybuilddir.txt
+
if test "$cross_compiling" = yes; then
AC_MSG_CHECKING([for python interpreter for cross build])
if test -z "$PYTHON_FOR_BUILD"; then