summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-21 16:29:59 (GMT)
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-21 16:29:59 (GMT)
commit40e320b31e51a8994725ae330884fdbfc043f357 (patch)
tree37c43c0b1a4dc2fc7426d156881d05e3b54f94d6 /configure.ac
parent708784255e42f0946ab36d2a55e4c4ae99b086ec (diff)
downloadcpython-40e320b31e51a8994725ae330884fdbfc043f357.zip
cpython-40e320b31e51a8994725ae330884fdbfc043f357.tar.gz
cpython-40e320b31e51a8994725ae330884fdbfc043f357.tar.bz2
Issue #28538: On Darwin net/if.h requires that sys/socket.h be included beforehand.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 61fad00..8099e27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3736,10 +3736,22 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_RESULT(no)
])
-# On Android API level 24 if_nameindex() is available, but the if_nameindex
-# structure is not defined.
+# On Android API level 24 with android-ndk-r13, if_nameindex() is available,
+# but the if_nameindex structure is not defined.
AC_MSG_CHECKING(for if_nameindex)
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+#include <stdio.h>
+#ifdef STDC_HEADERS
+# include <stdlib.h>
+# include <stddef.h>
+#else
+# ifdef HAVE_STDLIB_H
+# include <stdlib.h>
+# endif
+#endif
+#ifdef HAVE_SYS_SOCKET_H
+# include <sys/socket.h>
+#endif
#ifdef HAVE_NET_IF_H
# include <net/if.h>
#endif