summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2017-05-02 21:46:06 (GMT)
committerGitHub <noreply@github.com>2017-05-02 21:46:06 (GMT)
commit4dae0d111dd7bb34ec730eea2327a3219acff211 (patch)
tree10fa92f9dc514ff4ef073f180f859d7cbd8ef151 /configure.ac
parent3c422b92653df05c7034136b77f76376aa5aec4f (diff)
downloadcpython-4dae0d111dd7bb34ec730eea2327a3219acff211.zip
cpython-4dae0d111dd7bb34ec730eea2327a3219acff211.tar.gz
cpython-4dae0d111dd7bb34ec730eea2327a3219acff211.tar.bz2
[3.6] bpo-30232: Support Git worktree in configure.ac (#1398)
* bpo-30232: Support Git worktree in configure.ac (#1391) Don't test if .git/HEAD file exists, but only if the .git file (or directory) exists. (cherry picked from commit 5facdbb29169c2799c42f887cef4cd9d087b0167) * bpo-30232: Regenerate configure (#1396) Run autoconf. (cherry picked from commit 9ed34a89532763cf89f5e11fffb91ef7dee29fed)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6978b90..eda075d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,7 +29,7 @@ AC_SUBST(GITVERSION)
AC_SUBST(GITTAG)
AC_SUBST(GITBRANCH)
-if test -e $srcdir/.git/HEAD
+if test -e $srcdir/.git
then
AC_CHECK_PROG(HAS_GIT, git, found, not-found)
else