summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2016-09-11 00:45:33 (GMT)
committerBenjamin Peterson <benjamin@python.org>2016-09-11 00:45:33 (GMT)
commitcc1ea5dedc6aab819b9753eaa84ea6675fd8a126 (patch)
treec0a56e027c2402ddf02fa188480fc0afa85d99e1 /configure.ac
parent47503c5a8deab43ea24333498ef9fb6daeb0ba7e (diff)
downloadcpython-cc1ea5dedc6aab819b9753eaa84ea6675fd8a126.zip
cpython-cc1ea5dedc6aab819b9753eaa84ea6675fd8a126.tar.gz
cpython-cc1ea5dedc6aab819b9753eaa84ea6675fd8a126.tar.bz2
force gcc to use c99 inline semantics
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 328c610..a3df9a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1515,7 +1515,7 @@ AC_SUBST(UNIVERSAL_ARCH_FLAGS)
# tweak BASECFLAGS based on compiler and platform
case $GCC in
yes)
- CFLAGS_NODIST="$CFLAGS_NODIST -std=c99"
+ CFLAGS_NODIST="$CFLAGS_NODIST -std=c99 -fno-gnu89-inline"
# Python doesn't violate C99 aliasing rules, but older versions of
# GCC produce warnings for legal Python code. Enable