summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2017-03-21 03:41:52 (GMT)
committerGitHub <noreply@github.com>2017-03-21 03:41:52 (GMT)
commit554626ada769abf82a5dabe6966afa4265acb6a6 (patch)
tree062ff3ddcc18bd5e92fbbeca9d176bbda52e230f /configure.ac
parent4830f581af57dd305c02c1fd72299ecb5b090eca (diff)
downloadcpython-554626ada769abf82a5dabe6966afa4265acb6a6.zip
cpython-554626ada769abf82a5dabe6966afa4265acb6a6.tar.gz
cpython-554626ada769abf82a5dabe6966afa4265acb6a6.tar.bz2
bpo-27593: Revise git SCM build info. (#744)
Use --short form of git hash. Use output from "git describe" for tag. Expected outputs: 1. previous hg 2. previous git 3. updated git Release (tagged) build: 1. Python 3.7.0a0 (v3.7.0a0:4def2a2901a5, ... 2. Python 3.7.0a0 (v3.7.0a0^0:05f53735c8912f8df1077e897f052571e13c3496, ... 3. Python 3.7.0a0 (v3.7.0a0:05f53735c8, ... Development build: 1. Python 3.7.0a0 (default:41df79263a11, ... 2. Python 3.7.0a0 (master:05f53735c8912f8df1077e897f052571e13c3496, ... 3. Python 3.7.0a0 (heads/master-dirty:05f53735c8, ... "dirty" means the working tree has uncommitted changes. See "git help describe" for more info.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6e78bb6..aca8255 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,8 +37,8 @@ HAS_GIT=no-repository
fi
if test $HAS_GIT = found
then
- GITVERSION="git -C \$(srcdir) rev-parse HEAD"
- GITTAG="git -C \$(srcdir) name-rev --tags --name-only HEAD"
+ GITVERSION="git -C \$(srcdir) rev-parse --short HEAD"
+ GITTAG="git -C \$(srcdir) describe --all --always --dirty"
GITBRANCH="git -C \$(srcdir) name-rev --name-only HEAD"
else
GITVERSION=""