summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2019-04-29 19:07:39 (GMT)
committerGitHub <noreply@github.com>2019-04-29 19:07:39 (GMT)
commit883dfc668f9730b00928730035b5dbd24b9da2a0 (patch)
tree388cfc683fdd48f5454d2e6455c104a2db28e0cd /configure.ac
parentbe6dbfb43b89989ccc83fbc4c5234f50f44c47ad (diff)
downloadcpython-883dfc668f9730b00928730035b5dbd24b9da2a0.zip
cpython-883dfc668f9730b00928730035b5dbd24b9da2a0.tar.gz
cpython-883dfc668f9730b00928730035b5dbd24b9da2a0.tar.bz2
bpo-34602: Avoid failures setting macOS stack resource limit (GH-13011)
Under some conditions the earlier fix for bpo-18075, "Infinite recursion tests triggering a segfault on Mac OS X", now causes failures on macOS when attempting to change stack limit with resource.setrlimit resource.RLIMIT_STACK, like regrtest does when running the test suite. The reverted change had specified a non-default stack size when linking the python executable on macOS. As of macOS 10.14.4, the previous code causes a hard failure when running tests, although similar failures had been seen under some conditions under some earlier systems. For now, revert the original change and resume using the default stack size when linking the interpreter.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 7d2eff0..a02597d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2701,12 +2701,6 @@ then
# -u libsys_s pulls in all symbols in libsys
Darwin/*)
LINKFORSHARED="$extra_undefs -framework CoreFoundation"
-
- # Issue #18075: the default maximum stack size (8MBytes) is too
- # small for the default recursion limit. Increase the stack size
- # to ensure that tests don't crash
- LINKFORSHARED="-Wl,-stack_size,1000000 $LINKFORSHARED"
-
if test "$enable_framework"
then
LINKFORSHARED="$LINKFORSHARED "'$(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'