summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorE. M. Bray <erik.bray@lri.fr>2019-05-24 16:39:39 (GMT)
committerVictor Stinner <vstinner@redhat.com>2019-05-24 16:39:38 (GMT)
commitb1fc41784136a2eb9737a7f0c821db52ab8d4dee (patch)
tree6b0937ea07b911013f487c70150d5414b51ef5d9 /configure.ac
parentbc66faccb8a6140e7e07b5e67843b7f21152c144 (diff)
downloadcpython-b1fc41784136a2eb9737a7f0c821db52ab8d4dee.zip
cpython-b1fc41784136a2eb9737a7f0c821db52ab8d4dee.tar.gz
cpython-b1fc41784136a2eb9737a7f0c821db52ab8d4dee.tar.bz2
bpo-21536: Fix configure.ac for LIBPYTHON on Android/Cygwin (GH-13552)
Add also missing AC_MSG_RESULT for AC_MSG_CHECKING(MACHDEP).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 99d99ae..5e56519 100644
--- a/configure.ac
+++ b/configure.ac
@@ -411,6 +411,7 @@ then
'') MACHDEP="unknown";;
esac
fi
+AC_MSG_RESULT("$MACHDEP")
AC_SUBST(_PYTHON_HOST_PLATFORM)
if test "$cross_compiling" = yes; then
@@ -4622,10 +4623,10 @@ AC_MSG_RESULT($LDVERSION)
# On Android and Cygwin the shared libraries must be linked with libpython.
AC_SUBST(LIBPYTHON)
-if test -z "$ANDROID_API_LEVEL" -o "$MACHDEP" != "cygwin"; then
- LIBPYTHON=''
-else
+if test -n "$ANDROID_API_LEVEL" -o "$MACHDEP" = "cygwin"; then
LIBPYTHON="-lpython${VERSION}${ABIFLAGS}"
+else
+ LIBPYTHON=''
fi
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.