summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2017-09-04 17:09:12 (GMT)
committerGitHub <noreply@github.com>2017-09-04 17:09:12 (GMT)
commitfc96f1e95ef1d6edd1eb4538da40259866422c5a (patch)
treea95637327b785d049142b74c452a8d127676705a /configure.ac
parent1c1f8f30c03ca11952856f70ac5f0f7f8dcfd582 (diff)
downloadcpython-fc96f1e95ef1d6edd1eb4538da40259866422c5a.zip
cpython-fc96f1e95ef1d6edd1eb4538da40259866422c5a.tar.gz
cpython-fc96f1e95ef1d6edd1eb4538da40259866422c5a.tar.bz2
remove configure check for 'volatile' (#3281)
This is a required feature is C99, which we require.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index a5da830..af1cb8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4081,14 +4081,6 @@ AC_C_CHAR_UNSIGNED
AC_C_CONST
works=no
-AC_MSG_CHECKING(for working volatile)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[volatile int x; x = 0;]])],
- [works=yes],
- [AC_DEFINE(volatile, , [Define to empty if the keyword does not work.])]
-)
-AC_MSG_RESULT($works)
-
-works=no
AC_MSG_CHECKING(for working signed char)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[signed char c;]])],
[works=yes],