summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2017-09-04 23:36:05 (GMT)
committerGitHub <noreply@github.com>2017-09-04 23:36:05 (GMT)
commit069306312addf87252e2dbf250fc7632fc8b7da3 (patch)
tree92917032b65208b37ce8aeca6011d3eea30ce205 /configure.ac
parente1b0287c0440399e8cc855897113614fa5f6bc96 (diff)
downloadcpython-069306312addf87252e2dbf250fc7632fc8b7da3.zip
cpython-069306312addf87252e2dbf250fc7632fc8b7da3.tar.gz
cpython-069306312addf87252e2dbf250fc7632fc8b7da3.tar.bz2
remove IRIX support (closes bpo-31341) (#3310)
See PEP 11.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 57f4492..4ceeea8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,10 +134,6 @@ AC_DEFINE(_NETBSD_SOURCE, 1, [Define on NetBSD to activate all library features]
AC_DEFINE(__BSD_VISIBLE, 1, [Define on FreeBSD to activate all library features])
# The later defininition of _XOPEN_SOURCE and _POSIX_C_SOURCE disables
-# u_int on Irix 5.3. Defining _BSD_TYPES brings it back.
-AC_DEFINE(_BSD_TYPES, 1, [Define on Irix to enable u_int])
-
-# The later defininition of _XOPEN_SOURCE and _POSIX_C_SOURCE disables
# certain features on Mac OS X, so we need _DARWIN_C_SOURCE to re-enable
# them.
AC_DEFINE(_DARWIN_C_SOURCE, 1, [Define on Darwin to activate all library features])
@@ -406,7 +402,6 @@ then
linux*) MACHDEP="linux";;
cygwin*) MACHDEP="cygwin";;
darwin*) MACHDEP="darwin";;
- irix646) MACHDEP="irix6";;
'') MACHDEP="unknown";;
esac
fi
@@ -2402,7 +2397,7 @@ fi
AC_MSG_RESULT($SHLIB_SUFFIX)
# LDSHARED is the ld *command* used to create shared library
-# -- "cc -G" on SunOS 5.x, "ld -shared" on IRIX 5
+# -- "cc -G" on SunOS 5.x.
# (Shared libraries in this instance are shared modules to be loaded into
# Python, as opposed to building Python itself as a shared library.)
AC_MSG_CHECKING(LDSHARED)
@@ -2413,8 +2408,6 @@ then
BLDSHARED="Modules/ld_so_aix \$(CC) -bI:Modules/python.exp"
LDSHARED="\$(LIBPL)/ld_so_aix \$(CC) -bI:\$(LIBPL)/python.exp"
;;
- IRIX/5*) LDSHARED="ld -shared";;
- IRIX*/6*) LDSHARED="ld ${SGI_ABI} -shared -all";;
SunOS/5*)
if test "$GCC" = "yes" ; then
LDSHARED='$(CC) -shared'
@@ -2572,10 +2565,6 @@ then
then CCSHARED="-fPIC"
else CCSHARED="-Kpic -belf"
fi;;
- IRIX*/6*) case $CC in
- *gcc*) CCSHARED="-shared";;
- *) CCSHARED="";;
- esac;;
esac
fi
AC_MSG_RESULT($CCSHARED)