summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authoroctaviansoldea <octavian.soldea@intel.com>2017-09-08 19:14:33 (GMT)
committerGregory P. Smith <greg@krypto.org>2017-09-08 19:14:33 (GMT)
commit4c81401b3a9ffa48fc9e1ffff9963cbad5111e33 (patch)
tree9d55dc5abd1c0d6ae99657ae5dcce9ff1b8f00e9 /configure.ac
parentb3ad0e5127bdeb6e506301e0d65403fa23c4177b (diff)
downloadcpython-4c81401b3a9ffa48fc9e1ffff9963cbad5111e33.zip
cpython-4c81401b3a9ffa48fc9e1ffff9963cbad5111e33.tar.gz
cpython-4c81401b3a9ffa48fc9e1ffff9963cbad5111e33.tar.bz2
bpo-31354: Let configure --with-lto work on all builds
Allow configure --with-lto to apply to all builds, not just profile-opt builds. Whether this is actually useful or not must be determined by the person building CPython using their own toolchain. My own quick test on x86_64 Debian 9 (gcc 6.3, binutils 2.28) seemed to suggest that it wasn't, but I expect better toolchains can or will exist at some point. The point is to allow it at all.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9cded9f..88ab6a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1282,9 +1282,8 @@ else
fi
# Enable LTO flags
-AC_SUBST(LTOFLAGS)
AC_MSG_CHECKING(for --with-lto)
-AC_ARG_WITH(lto, AS_HELP_STRING([--with-lto], [Enable Link Time Optimization in PGO builds. Disabled by default.]),
+AC_ARG_WITH(lto, AS_HELP_STRING([--with-lto], [Enable Link Time Optimization in any build. Disabled by default.]),
[
if test "$withval" != no
then
@@ -1319,6 +1318,8 @@ if test "$Py_LTO" = 'true' ; then
esac
;;
esac
+ CFLAGS="$CFLAGS $LTOFLAGS"
+ LDFLAGS="$LDFLAGS $LTOFLAGS"
fi
# Enable PGO flags.