summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2015-07-02 18:27:56 (GMT)
committerStefan Krah <skrah@bytereef.org>2015-07-02 18:27:56 (GMT)
commite31db2a8214e338be8873a92f7c40c94a56c7078 (patch)
tree149982a81ee355db66cc05eac3282b5a03ea53c1 /configure.ac
parent49c521fd5d3102916045551019368eae66dc7696 (diff)
downloadcpython-e31db2a8214e338be8873a92f7c40c94a56c7078.zip
cpython-e31db2a8214e338be8873a92f7c40c94a56c7078.tar.gz
cpython-e31db2a8214e338be8873a92f7c40c94a56c7078.tar.bz2
Issue #24543: Use AC_LINK instead of AC_COMPILE in order to prevent false
positives with the -flto option (gcc >= 4.9.0 and clang).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4030e33..56a73df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3910,7 +3910,7 @@ fi],
# **************************************
AC_MSG_CHECKING(for x64 gcc inline assembler)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
+AC_LINK_IFELSE( [AC_LANG_PROGRAM([[]], [[
__asm__ __volatile__ ("movq %rcx, %rax");
]])],[have_gcc_asm_for_x64=yes],[have_gcc_asm_for_x64=no])
AC_MSG_RESULT($have_gcc_asm_for_x64)
@@ -4008,7 +4008,7 @@ fi
# so we try it on all platforms.
AC_MSG_CHECKING(whether we can use gcc inline assembler to get and set x87 control word)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
+AC_LINK_IFELSE( [AC_LANG_PROGRAM([[]], [[
unsigned short cw;
__asm__ __volatile__ ("fnstcw %0" : "=m" (cw));
__asm__ __volatile__ ("fldcw %0" : : "m" (cw));
@@ -4021,7 +4021,7 @@ then
fi
AC_MSG_CHECKING(whether we can use gcc inline assembler to get and set mc68881 fpcr)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
+AC_LINK_IFELSE( [AC_LANG_PROGRAM([[]], [[
unsigned int fpcr;
__asm__ __volatile__ ("fmove.l %%fpcr,%0" : "=g" (fpcr));
__asm__ __volatile__ ("fmove.l %0,%%fpcr" : : "g" (fpcr));