summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2013-01-08 18:49:42 (GMT)
committerCharles-François Natali <neologix@free.fr>2013-01-08 18:49:42 (GMT)
commitf6fd794fac1b6af754d233875c173afb5ca9c45e (patch)
treece318eebc2c7608cc3e4edecd2515f72cb2b1b95 /configure.ac
parent21b30827bcfcfebaca63b0470758683aa942eaf9 (diff)
downloadcpython-f6fd794fac1b6af754d233875c173afb5ca9c45e.zip
cpython-f6fd794fac1b6af754d233875c173afb5ca9c45e.tar.gz
cpython-f6fd794fac1b6af754d233875c173afb5ca9c45e.tar.bz2
Issue #16836: Enable IPv6 support even if IPv6 is disabled on the build host.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 3 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index ccb42d4..5ae0d5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2346,25 +2346,15 @@ AC_ARG_ENABLE(ipv6,
[
dnl the check does not work on cross compilation case...
- AC_RUN_IFELSE([AC_LANG_SOURCE([[ /* AF_INET6 available check */
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ /* AF_INET6 available check */
#include <sys/types.h>
-#include <sys/socket.h>
-main()
-{
- if (socket(AF_INET6, SOCK_STREAM, 0) < 0)
- exit(1);
- else
- exit(0);
-}
-]])],[
+#include <sys/socket.h>]],
+[[int domain = AF_INET6;]])],[
AC_MSG_RESULT(yes)
ipv6=yes
],[
AC_MSG_RESULT(no)
ipv6=no
-],[
- AC_MSG_RESULT(no)
- ipv6=no
])
if test "$ipv6" = "yes"; then