summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorstratakis <cstratak@redhat.com>2018-12-04 14:54:01 (GMT)
committerVictor Stinner <vstinner@redhat.com>2018-12-04 14:54:01 (GMT)
commitf92c7aa1ae81efa475b5aecf66e4711ef0f52c4c (patch)
tree139b7b75f0ffc39a3d75f028a242a8e7501e806e /configure.ac
parente63e617ebbe481c498bdf037a62e09f4f9f3963f (diff)
downloadcpython-f92c7aa1ae81efa475b5aecf66e4711ef0f52c4c.zip
cpython-f92c7aa1ae81efa475b5aecf66e4711ef0f52c4c.tar.gz
cpython-f92c7aa1ae81efa475b5aecf66e4711ef0f52c4c.tar.bz2
bpo-35351: Pass link time optimization flags to CFLAGS_NODIST (GH-10797)
When using link time optimizations, the -flto flag is passed to BASECFLAGS, which makes it propagate to distutils. Those flags should be reserved for the interpreter and the stdlib extension modules only, thus moving those flags to CFLAGS_NODIST.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 15d03ba..5c1c021 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1357,7 +1357,7 @@ if test "$Py_LTO" = 'true' ; then
LTOFLAGS="$LTOFLAGS -g"
fi
- BASECFLAGS="$BASECFLAGS $LTOFLAGS"
+ CFLAGS_NODIST="$CFLAGS_NODIST $LTOFLAGS"
LDFLAGS="$LDFLAGS $LTOFLAGS"
fi