summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2016-09-21 03:39:33 (GMT)
committerBenjamin Peterson <benjamin@python.org>2016-09-21 03:39:33 (GMT)
commit0c21214f3e583d541227df2239de377e796b55fa (patch)
tree154bfb91be848e117f6721523750bdc4afff8b71 /configure.ac
parentec2319c46d11e8f486e7def785339af5415a3559 (diff)
downloadcpython-0c21214f3e583d541227df2239de377e796b55fa.zip
cpython-0c21214f3e583d541227df2239de377e796b55fa.tar.gz
cpython-0c21214f3e583d541227df2239de377e796b55fa.tar.bz2
replace usage of Py_VA_COPY with the (C99) standard va_copy
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 0a140db..d55d38b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4038,20 +4038,6 @@ x.sa_len = 0;]])],
[AC_MSG_RESULT(no)]
)
-va_list_is_array=no
-AC_MSG_CHECKING(whether va_list is an array)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#ifdef HAVE_STDARG_PROTOTYPES
-#include <stdarg.h>
-#else
-#include <varargs.h>
-#endif
-]], [[va_list list1, list2; list1 = list2;]])],[],[
- AC_DEFINE(VA_LIST_IS_ARRAY, 1, [Define if a va_list is an array of some kind])
- va_list_is_array=yes
-])
-AC_MSG_RESULT($va_list_is_array)
-
# sigh -- gethostbyname_r is a mess; it can have 3, 5 or 6 arguments :-(
AH_TEMPLATE(HAVE_GETHOSTBYNAME_R,
[Define this if you have some version of gethostbyname_r()])