summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Panter <vadmium+py@gmail.com>2016-11-20 07:56:37 (GMT)
committerMartin Panter <vadmium+py@gmail.com>2016-11-20 07:56:37 (GMT)
commit395733d46bbc23d2f559eba4e5f75783f9bca6f1 (patch)
treebdc143f8538156bfd53d4a7d81cbd52b9b7f59d1 /configure.ac
parent1016b2ff00665203ae01d82520dac497ac89e5e7 (diff)
downloadcpython-395733d46bbc23d2f559eba4e5f75783f9bca6f1.zip
cpython-395733d46bbc23d2f559eba4e5f75783f9bca6f1.tar.gz
cpython-395733d46bbc23d2f559eba4e5f75783f9bca6f1.tar.bz2
Issue #10656: Fix out-of-tree building on AIX
The ld_so_aix script and python.exp file are created in the build directory. Patch by Tristan Carel and Michael Haubenwallner.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e55871..0886b6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2358,7 +2358,7 @@ if test -z "$LDSHARED"
then
case $ac_sys_system/$ac_sys_release in
AIX*)
- BLDSHARED="\$(srcdir)/Modules/ld_so_aix \$(CC) -bI:\$(srcdir)/Modules/python.exp"
+ BLDSHARED="Modules/ld_so_aix \$(CC) -bI:Modules/python.exp"
LDSHARED="\$(LIBPL)/ld_so_aix \$(CC) -bI:\$(LIBPL)/python.exp"
;;
IRIX/5*) LDSHARED="ld -shared";;