summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2016-06-07 09:25:43 (GMT)
committerVictor Stinner <victor.stinner@gmail.com>2016-06-07 09:25:43 (GMT)
commit9ff9cbd600f0290df20c73a31a9c4d43f3cf61d6 (patch)
tree7dfb6ce341c9fb0b9220d046f2e63805b773e16d /configure.ac
parentcb3a581636135556429b2036663e91c043c2bfd8 (diff)
parentdddf4849ec1750ca02d03b9772eff7141ba626f3 (diff)
downloadcpython-9ff9cbd600f0290df20c73a31a9c4d43f3cf61d6.zip
cpython-9ff9cbd600f0290df20c73a31a9c4d43f3cf61d6.tar.gz
cpython-9ff9cbd600f0290df20c73a31a9c4d43f3cf61d6.tar.bz2
Merge 3.5 (os.urandom)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0b026d0..1fbc655 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1881,7 +1881,7 @@ sys/param.h sys/select.h sys/sendfile.h sys/socket.h sys/statvfs.h \
sys/stat.h sys/syscall.h sys/sys_domain.h sys/termio.h sys/time.h \
sys/times.h sys/types.h sys/uio.h sys/un.h sys/utsname.h sys/wait.h pty.h \
libutil.h sys/resource.h netpacket/packet.h sysexits.h bluetooth.h \
-bluetooth/bluetooth.h linux/tipc.h spawn.h util.h alloca.h endian.h \
+bluetooth/bluetooth.h linux/tipc.h linux/random.h spawn.h util.h alloca.h endian.h \
sys/endian.h)
AC_HEADER_DIRENT
AC_HEADER_MAJOR
@@ -5246,12 +5246,13 @@ AC_LINK_IFELSE(
AC_LANG_SOURCE([[
#include <unistd.h>
#include <sys/syscall.h>
+ #include <linux/random.h>
int main() {
char buffer[1];
const size_t buflen = sizeof(buffer);
- const int flags = 0;
- /* ignore the result, Python checks for ENOSYS at runtime */
+ const int flags = GRND_NONBLOCK;
+ /* ignore the result, Python checks for ENOSYS and EAGAIN at runtime */
(void)syscall(SYS_getrandom, buffer, buflen, flags);
return 0;
}