summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGregory P. Smith ext:(%20%5BGoogle%20Inc.%5D) <greg@krypto.org>2016-11-20 21:17:01 (GMT)
committerGregory P. Smith ext:(%20%5BGoogle%20Inc.%5D) <greg@krypto.org>2016-11-20 21:17:01 (GMT)
commitfe914c034fc63ce26fec578d1a3a0c67bdea6880 (patch)
tree1f964be38275e67a6abacc7999517460f75514fd /configure.ac
parentf8d8d18c3319ee6675a232a213322ff8434c5b33 (diff)
parent164eea5443f56411d0e617389fa22b2025683f50 (diff)
downloadcpython-fe914c034fc63ce26fec578d1a3a0c67bdea6880.zip
cpython-fe914c034fc63ce26fec578d1a3a0c67bdea6880.tar.gz
cpython-fe914c034fc63ce26fec578d1a3a0c67bdea6880.tar.bz2
Rename the new --with-optimiations flag to --enable-optimizations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b915b06..bbc4212 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1281,8 +1281,8 @@ fi],
AC_SUBST(DEF_MAKE_ALL_RULE)
AC_SUBST(DEF_MAKE_RULE)
Py_OPT='false'
-AC_MSG_CHECKING(for --with-optimizations)
-AC_ARG_WITH(optimizations, AS_HELP_STRING([--with-optimizations], [Enable expensive optimizations (PGO, etc). Disabled by default.]),
+AC_MSG_CHECKING(for --enable-optimizations)
+AC_ARG_ENABLE(optimizations, AS_HELP_STRING([--enable-optimizations], [Enable expensive optimizations (PGO, etc). Disabled by default.]),
[
if test "$withval" != no
then
@@ -1405,7 +1405,7 @@ case $CC in
LLVM_PROF_ERR=yes
if test "${REQUIRE_PGO}" = "yes"
then
- AC_MSG_ERROR([llvm-profdata is required for a --with-optimizations build but could not be found.])
+ AC_MSG_ERROR([llvm-profdata is required for a --enable-optimizations build but could not be found.])
fi
fi
;;
@@ -1421,7 +1421,7 @@ case $CC in
LLVM_PROF_ERR=yes
if test "${REQUIRE_PGO}" = "yes"
then
- AC_MSG_ERROR([llvm-profdata is required for a --with-optimizations build but could not be found.])
+ AC_MSG_ERROR([llvm-profdata is required for a --enable-optimizations build but could not be found.])
fi
fi
;;
@@ -5399,7 +5399,7 @@ if test "$Py_OPT" = 'false' -a "$Py_DEBUG" != 'true'; then
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
echo "If you want a release build with all optimizations active (LTO, PGO, etc)," >&AS_MESSAGE_FD
- echo "please run ./configure --with-optimizations" >&AS_MESSAGE_FD
+ echo "please run ./configure --enable-optimizations" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
fi