summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKushal Das <kushaldas@gmail.com>2014-04-15 18:20:06 (GMT)
committerKushal Das <kushaldas@gmail.com>2014-04-15 18:20:06 (GMT)
commit02d23a212a1e8e45a29e06d3f91e119610b682a3 (patch)
treeb80ae813af32578a07c9fbe75dc60dfee0fb7af8 /configure.ac
parentcec96144755bc75bc82d34a27e17ebe4eb300992 (diff)
downloadcpython-02d23a212a1e8e45a29e06d3f91e119610b682a3.zip
cpython-02d23a212a1e8e45a29e06d3f91e119610b682a3.tar.gz
cpython-02d23a212a1e8e45a29e06d3f91e119610b682a3.tar.bz2
Closes Issue 17861: Autogenerate Include/opcode.h from opcode.py.
It includes required changes in Makefile.pre.in and configure.ac among other files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index abade0f..457819b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1036,6 +1036,15 @@ else
ASDLGEN="$PYTHON"
fi
+AC_SUBST(OPCODEHGEN)
+AC_CHECK_PROGS(PYTHON, python$PACKAGE_VERSION python3 python, not-found)
+if test "$PYTHON" = not-found; then
+ OPCODEHGEN="@echo python: $PYTHON! cannot run Tools/scripts/generate_opcode_h.py"
+else
+ OPCODEHGEN="$PYTHON"
+fi
+
+
case $MACHDEP in
bsdos*|hp*|HP*)