summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorZachary Ware <zachary.ware@gmail.com>2016-09-10 00:01:21 (GMT)
committerZachary Ware <zachary.ware@gmail.com>2016-09-10 00:01:21 (GMT)
commit935043d1ac19d07ac48233c6175250e66a7bbebd (patch)
treeb5a4d3b5202fbe75b904e8c35e141891ceb18dd6 /configure.ac
parentb7f3c944d1d0865ce797848e3a40c3ad9435b698 (diff)
downloadcpython-935043d1ac19d07ac48233c6175250e66a7bbebd.zip
cpython-935043d1ac19d07ac48233c6175250e66a7bbebd.tar.gz
cpython-935043d1ac19d07ac48233c6175250e66a7bbebd.tar.bz2
Closes #27976: Deprecate bundled full copy of libffi
Builds on non-OSX UNIX now default to using the system libffi, and warn if the bundled copy is used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 19 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 57cf46f..269c41e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2737,9 +2737,25 @@ AC_MSG_RESULT($with_system_expat)
# Check for use of the system libffi library
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
- AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),
- [],
- [with_system_ffi="no"])
+ AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),,,)
+
+case "$with_system_ffi" in
+ "")
+ case $ac_sys_system in
+ Darwin)
+ with_system_ffi="no"
+ ;;
+ *)
+ with_system_ffi="yes"
+ ;;
+ esac
+ ;;
+ yes|no)
+ ;;
+ *)
+ AC_MSG_ERROR([--with-system-ffi accepts no arguments])
+ ;;
+esac
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"