summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-03-27 21:47:00 (GMT)
committerGitHub <noreply@github.com>2021-03-27 21:47:00 (GMT)
commit064bc07f241dceec2fc577cbf5c31fa6d63fe320 (patch)
tree071dbf8d3fbe105183a03a9975f76b3a1053d843 /configure.ac
parent7990072999b7e9b4ef6b1f6bb376d441a5a41d74 (diff)
downloadcpython-064bc07f241dceec2fc577cbf5c31fa6d63fe320.zip
cpython-064bc07f241dceec2fc577cbf5c31fa6d63fe320.tar.gz
cpython-064bc07f241dceec2fc577cbf5c31fa6d63fe320.tar.bz2
[3.9] bpo-43617: Check autoconf-archive package in configure.ac (GH-25016) (GH-25034)
Signed-off-by: Christian Heimes <christian@python.org>. (cherry picked from commit 5d6e8c1c1a5f667cdce99cb3c563ac922198678d) Co-authored-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 972287a..45e0af4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,9 @@
-dnl ***********************************************
-dnl * Please run autoreconf to test your changes! *
-dnl ***********************************************
+dnl ***************************************************
+dnl * Please run autoreconf -if to test your changes! *
+dnl ***************************************************
+dnl
+dnl Python's configure script requires autoconf 2.69 and autoconf-archive.
+dnl
# Set VERSION so we only need to edit in one place (i.e., here)
m4_define(PYTHON_VERSION, 3.9)
@@ -9,7 +12,11 @@ AC_PREREQ([2.69])
AC_INIT([python],[PYTHON_VERSION],[https://bugs.python.org/])
-AC_CONFIG_MACRO_DIR(m4)
+m4_ifdef(
+ [AX_C_FLOAT_WORDS_BIGENDIAN],
+ [],
+ [AC_MSG_ERROR([Please install autoconf-archive package and re-run autoreconf])]
+)
AC_SUBST(BASECPPFLAGS)
if test "$srcdir" != . -a "$srcdir" != "$(pwd)"; then