summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Osipov <1983-01-06@gmx.net>2018-08-24 16:17:19 (GMT)
committerBerker Peksag <berker.peksag@gmail.com>2018-08-24 16:17:19 (GMT)
commit3738fadc670274ecc4649f51b52a93602820a375 (patch)
treede9743920d44b130229f599fe567156854df6912 /configure.ac
parent498845368ff0f6238750ab1d443e7cf4ec98ccd2 (diff)
downloadcpython-3738fadc670274ecc4649f51b52a93602820a375.zip
cpython-3738fadc670274ecc4649f51b52a93602820a375.tar.gz
cpython-3738fadc670274ecc4649f51b52a93602820a375.tar.bz2
bpo-34448: Improve output of usable wchar_t check (GH-8846)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1e0b7f5..5b66624 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4555,19 +4555,19 @@ then
AC_MSG_RESULT($ac_cv_wchar_t_signed)
fi
+AC_MSG_CHECKING(whether wchar_t is usable)
# wchar_t is only usable if it maps to an unsigned type
if test "$ac_cv_sizeof_wchar_t" -ge 2 \
-a "$ac_cv_wchar_t_signed" = "no"
then
- HAVE_USABLE_WCHAR_T="yes"
AC_DEFINE(HAVE_USABLE_WCHAR_T, 1,
[Define if you have a useable wchar_t type defined in wchar.h; useable
means wchar_t must be an unsigned type with at least 16 bits. (see
Include/unicodeobject.h).])
+ AC_MSG_RESULT(yes)
else
- HAVE_USABLE_WCHAR_T="no usable wchar_t found"
+ AC_MSG_RESULT(no)
fi
-AC_MSG_RESULT($HAVE_USABLE_WCHAR_T)
# check for endianness
AC_C_BIGENDIAN